Indirect reference is being made to assembly System.Web.Extensions version 3.5.0.0

The full error message is:

Error 1 Indirect reference is being made to assembly System.Web.Extensions version 3.5.0.0, which contains ‘AjaxControlToolkit.CalendarExtender’. This Project references a prior version of System.Web.Extensions version 1.0.61025.0. To use ‘AjaxControlToolkit.CalendarExtender’, you must replace the reference to System.Web.Extensions with version 3.5.0.0 or higher.

After some time finding for the cause, I realize that this is due to the me using the newer version of AjaxControlToolkit.dll. I should use the older version AjaxControlToolkit.dll for my ASP.NET 2.0 development.

Leave a Reply

Your email address will not be published. Required fields are marked *

*